How to Configure Switches for Seamless Roaming

Follow

With firmware version ng462 and later, Open-Mesh introduced a mechanism that allows user devices to roam seamlessly between different access points in a non-bridged SSID. Note that bridged SSIDs have seamless roaming enabled by nature. 

This mechanism requires the Ethernet switches in the LAN to be configured to forward VLAN tagged traffic (only some VIDs). Here's what to do:

  1. Dumb switches (which usually do not have a configuration interface) forward any kind of traffic without the need of applying any particular setting. Therefore, users with this kind of switch do not need to do anything.
  2. Smart switches need to be explicitly configured to permit VLAN tagged traffic to go through.

These are the VLAN IDs that need to be allowed either globally or only on ports with an Open-Mesh device attached:

Firmware ng560 and above:

  • 991 - Used for SSID 1 roaming, when bridged mode is disabled
  • 992 - Used for SSID 2 roaming, when bridged mode is disabled
  • 993 - Used for SSID 3 roaming, when bridged mode is disabled
  • 994 - Used for SSID 4 roaming, when bridged mode is disabled

Firmware ng500-560:

  • 989

Firmware ng481:

  • 998

Firmware ng462-480: (Only if bridge mode is enabled)

  • 999

The VLANs are used for mesh traffic only and do not need to be routed out to the Internet.

Note: if a network is running firmware older than ng481, we recommend upgrading to ng481 or later. 

Have more questions? Submit a request

Comments

  • Avatar
    Zach Boettner

    Can anyone tell me how to configure to allow this vlan traffic on Cisco Catalyst switches? And is this a global configuration or per port?

  • Avatar
    Bryan Patterson

    Per port is enough (VLAN traffic is exchanged only
    between nodes) but enabling it globally makes everything easier.

  • Avatar
    Luke Hamburg

    So if SSID#2 is bridged (which mine are) then the seamless roaming is not possible? Can someone explain the technical reason why this is?

  • Avatar
    Ryan Detwiller

    Bridged SSIDs have seamless roaming enabled by nature. The VLAN configuration above would still be required to handle roaming on non-bridged SSIDs. I've updated the article for clarity.

  • Avatar
    Alfred Harding

    Do Bridged SSIDs still show their individual Network names? I have three OM5P's and they all show when searching for a wifi connection. I only want two total. SSID 1 and SSID 2.

  • Avatar
    Patrick Turner

    Alfred, It doesn't matter whether it is bridged or not. Look under SSID 1 and 2, there is a network name section. If you want your actual network name to show that you've put, do not check the box that says "use node name". It will then broadcast just the individual network SSID across all AP"s.

  • Avatar
    Patrick Turner

    Just FYI of something I have found:
    I am using Cisco Catalyst switches, and have Spanning Tree enabled. I have OM2P-HS v1 and v2 nodes.

    If you are setting up the Access Point's as gateways, DO NOT set them on the same channel. These do not play well with Spanning Tree if you do. They drop connection like crazy because when the AP's see eachother they will try to mesh, but spanning tree sees it as a loop and cuts the connection.

    You need to manually change them to different channels as soon as you install each point. It's only when you use a repeater that you should put it on the same channel as the closest AP.

    I learned this the hard way last week: I didn't understand clearly about the bridged mode roaming and thought that the update to ng-r551 fixed the spanning tree problem and thought they still needed to be on the same channel to have seamless roaming. Now I have two dead nodes that won't check in. They are active and I can ping them, but they just don't do anything.

  • Avatar
    Reine Halldin

    This article is still unclear to me, Starts with saying that from ng462 roaming on non bridged SSID is possible and continues with -Firmware ng462-480: (Only if bridge mode is enabled)
    And what are the vID's used for? ( I can guess but would be nice if the article was updated)
    The article would also need to be updated on the spanning tree issue Patrick Turner mentioned, Should we set APs to different channels and will the seamless roaming work if we do?

  • Avatar
    John Sommatino

    I'm running v481 on OM2Ps. They are all connected to Cisco Cat switches and I have the same STP issues. The port flapping is crazy. I'm going to change the channels to disable the meshing, but it would be even nicer if there was a check box to disable the mesh individually on each unit under the "Add / Edit Node" button

  • Avatar
    Patrick Turner

    I've been meaning to post this for a while. Here is what they told me during my support request:

    "You don't need to put them all on the same channel to enable seamless roaming. We do some magic with VLANs in the background that will create a tunnel to the user's original gateway until the next DHCP refresh (usually about 10 mins). But in order for these VLANs to work you'll need to make sure your switch isn't stripping off our VLAN tags."
    They then provided a link to this article.

    "In general, it will be best to stagger your channels between 1, 6 and 11 so that you're minimizing interference across your network and if you ever add a repeater just make sure to set its channel to the same channel as the nearest gateway."

    That would be nice as John Sommatino said to add a "disable mesh" button on the add/edit node page that would auto-change the channels to set for least interference from the nearest AP.

    It would also be nice if you could modify the nodes on the "network status" page, just using the access points list/tab. And maybe if the graph could be swapped out with the map, so you could see node placement while looking at the access point list to get an overall information view.

    Also, as an update to my previous post, I re-flashed the 2 nodes I lost per their article and they are working just great now.

  • Avatar
    Ryan Detwiller

    Thanks for the feedback Patrick! We have a lot of this already in the works. I'll pass it on to our product team.

  • Avatar
    Manly Electronics

    Does Open-Mesh roaming implemented using 802.11k and 802.11r or some other way? Does it works only with some devices or any?

  • Avatar
    Ryan Detwiller

    @Dimitri - we use a proprietary method that holds onto authentication status, vouchers, etc. It works on any device.

  • Avatar
    Gary Herbstman

    We have also been thru this issue. We were having nodes drop off. Sometimes completely, sometimes into mesh mode.

    We changed the channels about 24 hours ago and so far so good. We would prefer to have them have the ability to mesh when needed and not cause these spanning-tree problems. Changing the adjacent channels is not always possible. For instance in a multi floor building the adjacency is often to 4 or more other nodes.

    I think the real solution is for the nodes to not create the switching loops that spanning-tree is picking up.

  • Avatar
    Zach Boettner

    HELP NEEDED!! Can anyone on this thread help us properly configure our network for optimal open-mesh operation? In a nutshell, our problem is that when our switchports are set as access ports the wifi functions somewhat but we get a lot of meshing which apparently creates loop errors (port has faulty link) on the catalyst 2960 switch.

    My understanding is the way to resolve the above issue is by following this "How to Configure Switches for Seamless Roaming" guide. However, when I change the switchports for the waps from access mode to trunk mode, and then set the vlan tag per ssid in cloudtrax, the waps seem unable to communicate to the internet as they all go dark in the cloudtrax dashboard. I've tried this several times, each time having to revert back to my original switch and ssid configuration. After pulling my hair out, I called my certified Cisco engineer, had him read this seemless roaming doc, he configured switch to his interpretation of the doc - setting the vlans globally on the switch and trunking all vlans to the wap ports, but still the waps failed to communicate and he gave up.

    What are we missing here? We love open-mesh but when we can't find real support anywhere we're having to rethink our choice for wifi gear. I really want to make this work and don't know who to call.

    Here is our access mode port config (works but seems to cause meshing and loops):

    interface FastEthernet0/12
    description access point
    switchport access vlan 10

    And here is the trunk mode port configuration with which the waps go dark:

    interface FastEthernet0/12
    description access point
    switchport trunk allowed vlan 10,128,989,991,992
    switchport mode trunk

    When attempting the trunk config, we tag our guest ssid1 with vlan 128, and private ssid2 with vlan 10.

    To add to our concern, we are about to open a brand new hotel and we will be installing an open-mesh wap in every other room. This new hotel is using a GPON fiber network to the rooms. All waps will be plugged directly into the GPON network. No Cisco switches will be involved. So question is, how to we configure this GPON network to optimally support the open-mesh waps? It should be straight forward per this "How to Configure Switches for Seamless Roaming", however, when we cannot even get it to work on our Cisco network we're a bit uneasy about trying it on the GPON network.

    Any help would be greatly appreciated.. We would gladly pay an open-mesh guru to help us address this.

  • Avatar
    Jeremy Hile-Hoffer

    We are using SSID1 for Guest and SSID2 for Bridge. SSID 2 has no takes (native vlan 321). Here is the working Cisco switch configuration.

    interface FastEthernet1/0/17
    description MERWAP03
    switchport trunk encapsulation dot1q
    switchport trunk native vlan 321
    switchport trunk allowed vlan 321,991
    switchport mode trunk

    If you enable bpdugaurd ports will go into err-disable.
    I am just starting to evaluate this. I will post more if I have anything.

  • Avatar
    Dinh Van Nghia

    Does Seamless Roaming work when I use many ISPs?

  • Avatar
    Bryan Patterson

    @ Dinh - No, seamless roaming will not work across different ISPs. The Cloudtrax network needs to be on the same LAN subnet in order for seamless roaming to work.

  • Avatar
    chrisb

    Can I check I'm understanding that "bridge mode enabled" means the SSID on CT is configured with a VLAN ID?

  • Avatar
    Bryan Patterson

    @Chrisb When a VLAN is configured for a n SSID it is bridged to that VLAN so you won't need to configure the VLAN setting for that SSID.

Powered by Zendesk